Problémy s aktualizáciou WordPress (staršia verzia PHP)

Odporúčame, aby ste aktualizácie WordPress pravidelne sledovali a podľa možnosti inštalovali.

Minoritné aktualizácie (napr. z verzie 5.3.1 na 5.3.2) si WordPress vie zariadiť sám, majoritné vyžadujú asistenciu administrátora stránky.

 

Problém s aktualizáciami pri staršej verzii PHP

Pri chode webových stránok odporúčame používať minimálne verziu PHP 7.3, ideálne 7.4. Všetky nové domény resp. služby zaregistrované u nás majú PHP 7.4 nastavenú ako východziu verziu. Pri starších službách však ešte môže byť nastavená verzia 5.5 alebo dokonca nižšia, čo spôsobuje problémy pri aktualizácii WordPress.

Či sa tento problém týka aj vašej verzie, ľahko zistíte nasledujúcim spôsobom:

Najprv pozrite na akej verzii "beží" váš WordPress (na úvodnej stránke v administrácii):

 

Kliknite na Aktualizovať a ak máte nastavenú kompatibilnú verziu PHP, tak aktualizácia prebehne bez problémov.

Ak máte staršiu verziu PHP, tak namiesto procesu aktualizácie uvidíte podobné hlásenie:
 

Nemôžete vykonať aktualizáciu, pretože WordPress 5.3.2 vyžaduje PHP verziu 5.6.20 alebo vyššiu.

Vy disponujete verziou 5.5.34.

Ak uvidíte hlásenie uvedené vyššie, pokračujte čítaním tohto návodu

 

Zmena PHP na vyššiu verziu

Prečítajte si návod Ako si zmeniť a zobraziť verziu PHP a ak máte verziu PHP nižšiu ako 5.6, tak si nastavte verziu na 5.6, uložte nové nastavenia a počkajte aspoň 15 minút pokým sa zmena prejaví na serveri.

Ak máte starší WordPress, napríklad 4.4.x ako v príklade, tak aktualizáciu musíte previesť na PHP verzii 5.6, takže nenastavujte si vyššiu verziu PHP (napr. 7.2), staršie WordPressy nie sú s touto verziou kompatibilné.

Keď bude PHP zmenené na verziu 5.6, teraz by už mala aktualizácia WordPress prebehnúť bez problémov.

A keďže WordPress sa aktualizuje na verziu 5.3.2 (resp. novšiu), tak po aktualizácii WordPress si môžete zmeniť PHP už na verziu 7.2 (resp. novšiu - 7.3, 7.4), čo aj odporúčame. Samozrejme nezabudnite ani na aktualizácie pluginov a šablón, vždy používajte najnovšie verzie.

Pre aktuálne verzie Wordpress 5.5.x a vyššie odporúčame používať PHP verziu 7.4